MTM2.com

A forum for mtm2 discussion
FAQ :: Search :: Members :: Groups :: Register
Login
It is currently Wed Oct 18, 2017 6:58 pm



Post new topic Reply to topic  [ 14 posts ] 
Author Message
 Post subject: Median Lines=Wont Align
PostPosted: Sun Mar 09, 2003 11:23 am 
Member

Joined: Sat Mar 08, 2003 2:01 pm
Posts: 18
Location: Macedonia,OH,US
Okay heres my prob, i have some nice textures. My textures align perfect, the white lines, the grass, the street, everything. Well except for one thing, the 2 yellow median lines in the middle. I have everything aligned except for this. I dont get it? Why is everything aligned perfect except for 2 yellow lines in the middle? Here is a pic of what i mean -->

http://geocities.com/dccustomz2/dietexture.jpg

Sorry if this seems "rookiesh" ive just never heard of anything like this before. Any help is appreciated, thanks =).


Top
 Profile  
 
 Post subject:
PostPosted: Sun Mar 09, 2003 11:46 am 
Member

Joined: Mon Mar 13, 2000 2:01 pm
Posts: 360
If you don't understand the 2 pixel overlap or just want to learn more about textures I suggest WK's tutorial .

If it has nothing to do with the mtm2 overlap then I suggest to just adjust them in psp. select the median lines and move them over a few pixels to a point in which they align and then fill in the clear portion from the moving of the textures.

edit:geocities doesn't allow linking, when i put your pic's link up your image appeared as well, then i removed it and i got the box with the X so i dont know, i guess ill leave the pic up.

http://ftp.teamslo.com/imup/dietexture.jpg


Top
 Profile  
 
 Post subject:
PostPosted: Sun Mar 09, 2003 12:01 pm 
Glow Ball
User avatar

Joined: Tue Feb 02, 1999 7:00 pm
Posts: 8
Geocities doesn't allow direct linking of images. Anyway...

If you used the template tutorial here, then I would guess that you rotated the straight textures for the top/bottom and left/right sections. If your textures are one hundred percent symmetrical, then that wouldn't have an effect, but the slightest variance, then bingo you get what you're seeing. The trick is not to rotate (for opposing parts). Make the straight part, paste it on twice, then slide it up for the top and down for the bottom. Same thing for left and right. Rotate the first ninety degrees, then paste it on twice... once for left and once for right. The problem happens when you try to match a top straight with a bottom straight, but they don't align. Using the same straight for both parts helps ensure you don't get this.

Of course, this assumes the textures you started with are good. An error in the template means misalignment in the game.


Top
 Profile  
 
 Post subject:
PostPosted: Sun Mar 09, 2003 2:18 pm 
Member
User avatar

Joined: Wed Mar 01, 2000 2:01 pm
Posts: 97
Location: California
Hard to say what went wrong without more information, but I think everyone who has made custom textures, has seen similar problems.

How many textures wide is your road? It looks like it is at least three. If so, does that mean the middle texture has the yellow lines and is actually the only misaligned one? If so, maybe just that one is rotated and a little off center? I have had similar problems when I started laying track from two different directions and found out they didn't match up when they met hehe.


Top
 Profile  
 
 Post subject:
PostPosted: Mon Mar 10, 2003 6:10 am 
Member

Joined: Sat Mar 08, 2003 2:01 pm
Posts: 18
Location: Macedonia,OH,US
ROFL, geocities ***** . Yep, 3 textures wide. It works perfectly, I think i get the 2 pixel overlap, i just found it vague when someone else tried explaining it to me. Thanks =)


Top
 Profile  
 
 Post subject:
PostPosted: Mon Mar 10, 2003 6:20 am 
Member

Joined: Sat Mar 08, 2003 2:01 pm
Posts: 18
Location: Macedonia,OH,US
My bad, accidently pressed post reply. Ok, everything aligns up in PSP. Its definitely from when i paste into traxx. The yellow lines are the only part of texture that do not align. They are the middle of the 3 texture wide texture. Ok so with the 2 pixel overlap, I will leave 2 pixels on every edge of every 64x64 texture? Im really confused. Im trying to understand this turtoial. I will keep trying. Thanks for yer help.


Top
 Profile  
 
 Post subject:
PostPosted: Mon Mar 10, 2003 6:34 am 
Glow Ball
User avatar

Joined: Tue Feb 02, 1999 7:00 pm
Posts: 8
Don't paste into traxx (if you don't have to). Use Slice60 instead.

http://mtm2.com/~mtmg/slice60/

You might find this interesting too

http://rhinoseros.com/~mtmg/templates/


Top
 Profile  
 
 Post subject:
PostPosted: Mon Mar 10, 2003 8:25 am 
Member

Joined: Sat Mar 08, 2003 2:01 pm
Posts: 18
Location: Macedonia,OH,US
Ive tried slice60, it makes my textures totally misaligned. Maybe im doing it wrong, ill try again. I like my own style of making textures, Winterkill's way is cool but its not for me. I create the 90degree turn and paste it. Simple enough? Well Phin, ima give slice60 a try, thanks again bud.


Top
 Profile  
 
 Post subject:
PostPosted: Mon Mar 10, 2003 9:23 am 
Member

Joined: Sat Mar 08, 2003 2:01 pm
Posts: 18
Location: Macedonia,OH,US
Ok phin, im mad now. I redid the whole texture so it was 60x60 for each thing and made the whole template to come out to 540x540. It looked beautiful, everything aligned again..except for the median lines! I followed all of yer guidelines and it still doesnt work. I am hoping that maybe its just traxx making it look like that. Nope, just tried it in mtm2. Ok man, im getting to the point of saying screw these median lines..lol.


Top
 Profile  
 
 Post subject:
PostPosted: Mon Mar 10, 2003 10:21 am 
easy company
User avatar

Joined: Tue Feb 29, 2000 2:01 pm
Posts: 2018
can you post a picture of the problem area? or you could send me the problem one's so I can get a better understading of what's happening?

I've fixed a couple hundred that tri passed so there's not much I haven't seen or couldn't help you with but trying to get an understanding from your description is difficult... I've even been successful with lines that intersect at four grid squares.


Top
 Profile  
 
 Post subject:
PostPosted: Mon Mar 10, 2003 11:23 am 
Glow Ball
User avatar

Joined: Tue Feb 02, 1999 7:00 pm
Posts: 8
See if this helps.



<center><img src="http://cownap.com/~forum/pics/yellowlinefever.gif"></center>


Given this, we realize it's best to make the median line an even number of pixels in width. Odd widths "must" cause problems.

And this is one reason why you'd make textures from a full circle set rather than just a corner segment. Still, if your measurements are right on, there's no reason it wouldn't work.

And if all else fails, send mal your bmp/tga image. The guy's a wizard.


Top
 Profile  
 
 Post subject:
PostPosted: Mon Mar 10, 2003 11:42 am 
easy company
User avatar

Joined: Tue Feb 29, 2000 2:01 pm
Posts: 2018
whoops I just realized he did post a pic heheh I saw the one under Kdawgs post and didn't know it was DKs open yer eyes mal lol... it's been a long day... from here it looks like a simple fix by just shifting the line over by a couple pixels at one end.


Top
 Profile  
 
 Post subject:
PostPosted: Tue Mar 11, 2003 4:56 am 
Member

Joined: Sat Mar 08, 2003 2:01 pm
Posts: 18
Location: Macedonia,OH,US
Everything is perfectly even. I have been making textures for like a year now, im no fook. I know they have to be exactly symetrical, which indeed they are. Im taking it that it is a game error or something towards that matter. This template is for the expo? I dont think it would be a good idea for somebody to help me? Im going to keep trying, and if all else fails i will just delete the median lines. Thanks for all your help.


Top
 Profile  
 
 Post subject:
PostPosted: Tue Apr 05, 2005 3:09 pm 
MTM2 Fanatic

Joined: Thu Sep 04, 2003 1:48 pm
Posts: 671
>>Traxx - won't work the best

I paste my textures into Traxx all the time. Well, if you mean Paste Composite, that is. This function will not work right unless all road on your track is at least one grid square (60 pixels) from the edge of the texture layout picture to be copied. When selecting the offset from top and left, enter 58. Then it will align.

If you need the texture further down or right, just add 60 to that number; it will not align if you continue to add 58.


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 14 posts ] 


Who is online

Users browsing this forum: No registered users and 2 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group