MTM2.com

A forum for mtm2 discussion
FAQ :: Search :: Members :: Groups :: Register
Login
It is currently Mon Nov 12, 2018 3:10 pm



Post new topic Reply to topic  [ 10 posts ] 
Author Message
 Post subject: Strange errors
PostPosted: Wed Nov 08, 2017 1:39 am 
Member
User avatar

Joined: Wed May 14, 2008 7:20 am
Posts: 451
Location: Behind you
So I've been having a few issues lately with MTM2 on my laptop. The game runs fine for a couple races, but after the first two or three it starts giving me errors when I try to enter gameplay. Most of the errors have been the usual "missing texture" it never names a texture, only listing some black boxes (think corrupted font) or gives me something about "matrix overload." The errors aren't consistent either, I can get an error on the same track 2 or 3 times and then it miraculously decodes to work on the 4th, but I usually have to quit and restart the game after every so many races.

If I could, I'd post pics but my laptop has no WiFi and for some reason my retarded phone won't let me image link. I hope I made enough sense to understand

_________________
Celebrating 10-ish years of MTM2 (I think...)

Admin of the MTM2 Draggers facebook page, find it here!
https://m.facebook.com/groups/337032006 ... =bookmarks


Top
 Profile  
 
 Post subject: Re: Strange errors
PostPosted: Wed Nov 08, 2017 5:07 am 
Member
User avatar

Joined: Mon Jul 02, 2001 2:01 pm
Posts: 1309
Location: Lost in Translation
I have had the missing texture error. It's very random on my end and I cannot properly replicate it (as in have it happen two times the same way).

The matrix overload I have not encountered yet. Is this when using Direct3D or nGlide? (and does it make a difference if you are using between the two?)


Top
 Profile  
 
 Post subject: Re: Strange errors
PostPosted: Mon Nov 27, 2017 12:32 pm 
Member
User avatar

Joined: Wed May 14, 2008 7:20 am
Posts: 451
Location: Behind you
Sorry it took me. I use nGlide when I play, haven't tried direct3d. I also found a couple more things. When I go into gameplay, there's about a 50/50 chance I'll spawn under the map locked in free-fall until I restart the race. I was beta testing a truck the other day, and for some reason whenever it spawns it's either partially underground or floating above ground. I can throttle up and down, steer, shift gears, etc but the truck is locked in place and can't move. I've tried it on several tracks and garage settings and got the same results whatever I use, the only thing changing is where the truck sits when it loads. At first I thought it may have had something to do with the truck having small tires, but I tried it with full size monster wheels and got the same results.

_________________
Celebrating 10-ish years of MTM2 (I think...)

Admin of the MTM2 Draggers facebook page, find it here!
https://m.facebook.com/groups/337032006 ... =bookmarks


Top
 Profile  
 
 Post subject: Re: Strange errors
PostPosted: Mon Nov 27, 2017 1:24 pm 
Member
User avatar

Joined: Mon Jul 02, 2001 2:01 pm
Posts: 1309
Location: Lost in Translation
There's something wrong with the truck specifically. I'm not a truck builder so I don't know the ins and the outs but it means there's a very small detail that is getting overlooked.

For example Cale had a similar issue, that hasn't been encountered before.

Quote:
Q: Can someone tell me why this is crashing my game? It goes 10 feet then is shot to the middle of nowhere, then when you start a race with a truck that does work, the tires don't roll. I've had a lot of odd bugs with this game, but never something like this.
A: Found the issue! BinEdit's Truck Editor defaults to a comically high number if you click elsewhere when pasting a value from a different line. So I had one scrape point located in an area the game wouldn't recognize, and it just shot the truck to nowhere. Were's good now. :mrgreen:


Top
 Profile  
 
 Post subject: Re: Strange errors
PostPosted: Mon Nov 27, 2017 1:30 pm 
Member
User avatar

Joined: Mon Jul 02, 2001 2:01 pm
Posts: 1309
Location: Lost in Translation
As for the texture error thing. I've looked around mtmg, this error does exist but there is no known solution. People have unmounted and then re-mounted the track giving the error and it magically worked. It's one of those weird errors that makes no sense.

As far as the matrix overload, have you tried, just for testing, to see if it gives the same error when using direct3d? If it does then... meh. Maybe a game reinstall will help?


Top
 Profile  
 
 Post subject: Re: Strange errors
PostPosted: Mon Nov 27, 2017 2:01 pm 
Member
User avatar

Joined: Wed May 14, 2008 7:20 am
Posts: 451
Location: Behind you
Ok, I switched it to Direct3d and ran a few races. Usually the breaking point for nGlide is 3 races, and I think I made it to 5 on Direct3D but I still got the matrix error. On a side note, the game did run and look better for me with Direct3D but I got that bug where the objects are cut off above ground level.

_________________
Celebrating 10-ish years of MTM2 (I think...)

Admin of the MTM2 Draggers facebook page, find it here!
https://m.facebook.com/groups/337032006 ... =bookmarks


Top
 Profile  
 
 Post subject: Re: Strange errors
PostPosted: Mon Nov 27, 2017 2:14 pm 
Member
User avatar

Joined: Mon Jul 02, 2001 2:01 pm
Posts: 1309
Location: Lost in Translation
See the dgVoodoo thread. I am currently in the middle of testing it and glide seems to be better in dgVoodoo than when using nGlide.

You can also use direct3d with dgVoodoo. Based on my testing it increases my fps between 50%-100% but it displays some artifact issues (like bad transparency and/or objects cut above ground) but it's maybe worth a try.

Sorry I can't help about the matrix error. Never received it. Wonder if it's video card based.

Edit: Especially I wonder if it's video card based since, for example, I don't have the objects above ground clipping issue in Direct3D).


Top
 Profile  
 
 Post subject: Re: Strange errors
PostPosted: Mon Nov 27, 2017 4:09 pm 
Member
User avatar

Joined: Wed May 14, 2008 7:20 am
Posts: 451
Location: Behind you
from what I've seen, I think the graphics bug almost seems to be a problem with newer operating systems, because it's happened to me on every rig I have running anything newer than Windows XP. That's just a guess, but it's my two cents on the matter. Both of my laptops have windows 7 (which is where I first experienced it) and it happened again when I tried to play it on Windows 10 as well. Installing nGlide fixed it on windows 7, never got the chance to try it on 10 before my game got messed up.

_________________
Celebrating 10-ish years of MTM2 (I think...)

Admin of the MTM2 Draggers facebook page, find it here!
https://m.facebook.com/groups/337032006 ... =bookmarks


Top
 Profile  
 
 Post subject: Re: Strange errors
PostPosted: Mon Nov 27, 2017 4:19 pm 
Member
User avatar

Joined: Mon Jul 02, 2001 2:01 pm
Posts: 1309
Location: Lost in Translation
It's a combination of the video card and the new operating systems yes. The primary issue is the new operating system(s) as they have changed the way games are being rendered (for example directx5-7 is obsolete and directx9-12 use workarounds to still render old games). Then it's a crap shoot as far as video cards as some work, some don't.

But in regards to the matrix error. MTM2 did have some specific video card errors. In the old days they were mostly with ATI video cards. Who knows how the game interprets the laptop cards.


Top
 Profile  
 
 Post subject: Re: Strange errors
PostPosted: Tue Nov 28, 2017 11:28 am 
Member
User avatar

Joined: Mon Jul 02, 2001 2:01 pm
Posts: 1309
Location: Lost in Translation
Hopefully the upcoming community patch 2 will fix your matrix issue... hopefully.


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 10 posts ] 


Who is online

Users browsing this forum: No registered users and 19 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group