MTM2.com

A forum for mtm2 discussion
FAQ :: Search :: Members :: Groups :: Register
Login
It is currently Sun Sep 23, 2018 4:58 pm



Post new topic Reply to topic  [ 5 posts ] 
Author Message
 Post subject: Strange truck bug
PostPosted: Tue Feb 20, 2018 12:28 am 
Member
User avatar

Joined: Wed May 14, 2008 7:20 am
Posts: 449
Location: Behind you
Having trouble with another project. It's a small tires truck. I've combed through the model and can't find any stray vertices or faces and can't find anything. When I put the truck in game, depending on the track, it does one of 3 things:
1: The truck spawns with the tires part way submerged in the ground. The truck will accelerate and turn, but the model is completely static and frozen in place.
2: Spawns a foot above ground. The tires spin and the truck accelerates and steers, but again the truck doesn't move.
3: The truck spawns under the map and is locked in perpetual free-fall. I can only fix this by restarting the race.
I've tried the helicopter and it does work, but the truck still won't move afterward. Any ideas? I've put too much work into it to let it be scrapped because of a bug. Also, if it means anything, the machine I have it on runs community patch 1

_________________
Celebrating 10-ish years of MTM2 (I think...)

Admin of the MTM2 Draggers facebook page, find it here!
https://m.facebook.com/groups/337032006 ... =bookmarks


Top
 Profile  
 
 Post subject: Re: Strange truck bug
PostPosted: Mon Mar 19, 2018 8:39 pm 
Member
User avatar

Joined: Sat Oct 17, 2015 3:23 pm
Posts: 53
Location: United States
That's a strange problem. I never experienced it, so I'm not sure why it happens, nor how it can be fixed.

_________________
Image


Top
 Profile  
 
 Post subject: Re: Strange truck bug
PostPosted: Mon Mar 19, 2018 9:04 pm 
MTM2 Fanatic

Joined: Thu Sep 04, 2003 1:48 pm
Posts: 677
It sounds like there might be a configuration issue with the .trk file. I'd suggest making a fresh one (with just your custom model names filled in) and perhaps re-applying each of your setup tweaks until either it fails again (in which case you've found what adjustment caused the problem) or you finish (in which case all is good in the world).

Relevant: One of our favorite quotes from the MTMG error/fix list:
Phineus wrote:
The solution is to fix the errors.


Top
 Profile  
 
 Post subject: Re: Strange truck bug
PostPosted: Mon Mar 19, 2018 9:20 pm 
Member
User avatar

Joined: Mon Oct 27, 2003 7:28 pm
Posts: 519
Are you using the Binedit truck editor? Sometimes putting in an invalid coordinate will cause it to default to a massive negative number that totally borks the truck. I'd check there first.


Top
 Profile  
 
 Post subject: Re: Strange truck bug
PostPosted: Wed Mar 21, 2018 7:47 pm 
Member
User avatar

Joined: Wed May 14, 2008 7:20 am
Posts: 449
Location: Behind you
Thanks guys, I'll try both options.

_________________
Celebrating 10-ish years of MTM2 (I think...)

Admin of the MTM2 Draggers facebook page, find it here!
https://m.facebook.com/groups/337032006 ... =bookmarks


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 5 posts ] 


Who is online

Users browsing this forum: No registered users and 9 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group