MTM2.com

A forum for mtm2 discussion
FAQ :: Search :: Members :: Groups :: Register
Login
It is currently Thu May 24, 2018 2:52 pm



Post new topic Reply to topic  [ 12 posts ] 
Author Message
 Post subject: BinEdit v2.0 tr23
PostPosted: Fri Oct 31, 2003 9:51 pm 
easy company
User avatar

Joined: Tue Feb 29, 2000 2:01 pm
Posts: 2018
BinEdit20tr23.zip



This version addresses a few issues that test release 22 had.

1) The 'resize' mirror trick that was lost in the last release has been replaced with a straight up mirror function now found under the model menu. You simply select along which axis to be mirrored and BinEdit will mirror all vertices. If you select the faces beforehand BinEdit will also flip the faces for you as it mirrors. Finaly if you select all faces 'and' check the 'mirror copy' box BinEdit will create and place a mirrored copy and all you need to do is merge the vertices if so desired.

2) We added a unused vertice detect prompt at save. What this does is if your model has any unused verts and you go to save the model BinEdit will alert you and give you several options before saving. You can disable this if you wish under preferences.

3) Save prompt at texture replace restored

4) Save prompt at unused vertice delete restored

5) Restored current vertice highlight marker in quad view

6) fixed the 'open in active window' preference not 'sticking'

7) fixed the Alt+* vertice group translation refresh (win98 only bug)

the Tools menu is disabled because it's not quite ready. I wanted to get this version out that adresses the above issues first. When it's ready it'll have a full blown truck editor complete with previews and also a pod compiler, decompiler.


Top
 Profile  
 
 Post subject:
PostPosted: Sat Nov 01, 2003 1:29 am 
Glow Ball
User avatar

Joined: Tue Feb 02, 1999 7:00 pm
Posts: 11
Excellent work, Mal.

Help and binedit pages have been updated.

http://binedit.com/
http://binedit.com/help/

Please say thanks to RBIII for us.


Top
 Profile  
 
 Post subject:
PostPosted: Sat Nov 01, 2003 5:31 am 
Member
User avatar

Joined: Wed Jan 08, 2003 2:01 pm
Posts: 55
Location: Springwood, NSW, Australia
so i should update mtmr right heh

i need to do some major tidying up on the server, and i cant say i havent had a chance ive just been extra lazy lately...all in good tiome

_________________
<img border="0" src="http://forum.mtm2.com/images/smiles/smilie_nyuk.gif">


Top
 Profile  
 
 Post subject: Re: BinEdit v2.0 tr23
PostPosted: Sat Nov 08, 2003 2:45 pm 
MTM2 Fanatic

Joined: Thu Sep 04, 2003 1:48 pm
Posts: 677
Malibu350 wrote:
... because it's not quite ready. I wanted to get this version out that adresses the above issues first. When it's ready it'll have a full blown truck editor complete with previews and also a pod compiler, decompiler.


I can't wait till then!!!!!


Top
 Profile  
 
 Post subject:
PostPosted: Sun Nov 09, 2003 8:13 pm 
Member
User avatar

Joined: Sat May 11, 2002 2:01 pm
Posts: 247
Location: surrey, bc, canada
well i got a problem here.
mirroring an object and then inserting another object. as i go to insert the second object, it prompts me to save. i click "no" and it gives me this box....

Image

doesnt matter which button i press i gives me this....

Image

then shuts down.

_________________
Leg's Auto Emporium most anything that you'll need to make a truck!


Top
 Profile  
 
 Post subject:
PostPosted: Sun Nov 09, 2003 10:14 pm 
easy company
User avatar

Joined: Tue Feb 29, 2000 2:01 pm
Posts: 2018
I've tried with both XP and w98 mirroring and inserting (multiple times) then saving with no errors. Either I am missing a step here or the model is in a specific state, ie.. has some unused verts or perhaps was just remapped in the same session.
If you can reproduce this let me know exactly, step by step, what led up to the crash. It would help a great deal since there's so many variables that can come into play.

>> as i go to insert the second object, it prompts me to save.

BE should never prompt you to save while you're working. The save button will activate if you make any changes but you should not be prompted with a pop up unless you try to close a model after changes were made.

>> doesnt matter which button i press i gives me this....

on rare occations ignore will allow you to continue but for the most part that dialog is only for debugging purposes.


Top
 Profile  
 
 Post subject:
PostPosted: Mon Nov 10, 2003 12:32 am 
Member
User avatar

Joined: Wed Nov 06, 2002 2:01 pm
Posts: 881
Location: Silicon Valley, California. USA
I tried it on both win98 and winXP pro, and I have no problems.

QUESTION: WHy does the error message say Binedit.exe is in a folder called "projects\JEEP\". My copy of BE2 is installed in my Monster Truck Madness 2 folder. (C:\Monster Truck Madness 2\Binedit 2.0.exe).

Do you move Binedit to different folders, depending on what project you are working on? (\jeep\ in this case)

Could the chosen install directory be a source of problems?

----------------------------------

Two more questions: Possible no help, but who knows?

1. did you flip faces before selecting INSERT?

2. What axis did you mirror on?

----------------------------------

And finally, can you repeat the error you encountered?...perhaps your machine was ready for a reboot......try restarting and see if the error still appears

----------------------------------
As a last resort, can you send Mal the exact models and textures you used, so he can try to duplicate your error more accurately?

_________________
--> "Obstacles are those frightful things you see when you take your eyes off your goals." -- Henry Ford


Top
 Profile  
 
 Post subject:
PostPosted: Mon Nov 10, 2003 2:12 am 
Member
User avatar

Joined: Sat May 11, 2002 2:01 pm
Posts: 247
Location: surrey, bc, canada
Quote:
Do you move Binedit to different folders, depending on what project you are working on? (\jeep\ in this case)

i have many installs of BE 2.0 on this machine. one of which is in the jeep folder.

Quote:
can you repeat the error you encountered?


everytime. even after a reboot.

these are the steps i took to arrive at this error.


1) open half-model....
http://legwon.biz/pics/be/be_ins1.jpg

2) go to ... model/mirror.. and set the prefs...
http://legwon.biz/pics/be/be_ins2.jpg

everythings good up to this point...


3) insert/model..
http://legwon.biz/pics/be/be_ins3.jpg

4) select the model i want to insert... i get the save prompt.
http://legwon.biz/pics/be/be_ins4.jpg

5) when i press no, it gives me the above error.

_________________
Leg's Auto Emporium most anything that you'll need to make a truck!


Top
 Profile  
 
 Post subject:
PostPosted: Mon Nov 10, 2003 2:45 am 
Glow Ball
User avatar

Joined: Tue Feb 02, 1999 7:00 pm
Posts: 11
I followed your instructions and it worked fine, so I closed binedit. Then I thought, I had to set prefs before doing it - maybe leg is inadvertently opening from the non default models folder, so I went back to check if the prefs saved and what they were (just double checking) but when re-opening binedit, I got this:

Code:
Debug Assertion Failed

Program e:\blah\blah\blah\BinEdit.exe
File: fgets.c
Line 60

Expression str != NULL


No picture, tho, cuz whatever the problem was ate up all resources. I had to reboot. But take it with a grain of salt. Something's not quite right on my system. Something messed with psp and netscape earlier this evening. I also got a new mtm error too... about sound card settings.


Top
 Profile  
 
 Post subject:
PostPosted: Mon Nov 10, 2003 3:06 am 
Member
User avatar

Joined: Wed Nov 06, 2002 2:01 pm
Posts: 881
Location: Silicon Valley, California. USA
Quote:
have many installs of BE 2.0 on this machine. one of which is in the jeep folder.


Instead of doing that, why not just have one copy of B.E. installed, and then place multiple shortcuts to it in the different project folders you use...that would be more efficent.

I just set my preferences to look at whatever BIN model folder I am working with.....your multiple .EXE files could be causing your unique problem..hard to say. I've never seen anyone do multiple installs with Binedit before.

_________________
--> "Obstacles are those frightful things you see when you take your eyes off your goals." -- Henry Ford


Top
 Profile  
 
 Post subject:
PostPosted: Mon Nov 10, 2003 3:35 am 
Glow Ball
User avatar

Joined: Tue Feb 02, 1999 7:00 pm
Posts: 11
> I've never seen anyone do multiple installs with Binedit before.

Really? I've used multi binedits, multi traxx, multi mtm2s (had three or four at one time - now I just do multi tracked2s). I think traxx is the only one that uses the registry.

[ edit ] I found part of my problem (from above). Something dumped 37,000 files in the system temp directory. Windows explorer couldn't even display them, I had to delete from dos.


Top
 Profile  
 
 Post subject:
PostPosted: Mon Nov 10, 2003 10:42 am 
Member
User avatar

Joined: Sat May 11, 2002 2:01 pm
Posts: 247
Location: surrey, bc, canada
well i figured out the problem.. bad texture associations.
went to each model and associated with the proper textures... evetythings fine now. [bump]

_________________
Leg's Auto Emporium most anything that you'll need to make a truck!


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 12 posts ] 


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group