MTM2.com

A forum for mtm2 discussion
FAQ :: Search :: Members :: Groups :: Register
Login
It is currently Wed Jul 18, 2018 1:36 pm



Post new topic Reply to topic  [ 9 posts ] 
Author Message
 Post subject: Disable Autoplay in XP
PostPosted: Tue Aug 03, 2004 9:16 pm 
Glow Ball
User avatar

Joined: Tue Feb 02, 1999 7:00 pm
Posts: 11
Since Fila had asked a while back about turning off auto play and since it was something I figured I could live without, I found a solution where you goto the drive's properties and on the auto play tab, disable it for the items you want.

http://mtm2.com/~forum/images/turnoffau ... rties1.gif

Myself, I found it a bit of a pain to set each item on each drive one by one, but it worked so what the hey.

For Fila, of course, it was a different story entirely. For him, it was either too complicated (what, with clicking properties and all) or he just couldn't follow basic instructions (or something), and he's been living with autoplay still doing it's nasty annoying stuff. That is, until recently when he found an alternate, perhaps more thorough way of doing it.

Here's a pic

http://mtm2.com/~forum/images/turnoffau ... rties2.gif

And here's the source quote.



Quote:
Disable Autoplay in XP / Group Policy Editor

Interesting, simple, example on using the group policy editor. Specifically, using it to disable autoplay on CDROMS in WinXP.

Grabbed from Deja.com:

How to disable Auto-insert notification on CDROMs
microsoft.public.windowsxp.general
Date: 2002-02-13 14:10:55 PST

Start, Run, GPEDIT.MSC Computer Configuration, Administrative
templates, System, Turn off autoplay.

To Disable cD autoplay, completely, in Windows XP Pro

1) Click Start, Run and enter GPEDIT.MSC

2) Go to Computer Configuration, Administrative Templates, System.

3) Locate the entry for Turn autoplay off and modify it as you desire.

Note: It might be easier to just grab TweakUI and use that. Although it doesn't seem to work that well...

Note 2: This works in XP Professional only. XP Home does not come with gpedit.msc.

http://www.lc.yi.org/scribble/scribble_ ... p3?sid=146



I post this because it may come in handy after anybody does a reinstall.

Enjoy.


Top
 Profile  
 
 Post subject:
PostPosted: Wed Aug 04, 2004 4:28 am 
Member
User avatar

Joined: Mon Jul 02, 2001 2:01 pm
Posts: 1298
Location: Lost in Translation
Smartass. :)

Just so you know, the "turn off autoplay properties" (take no action) has never ever worked for me.
I kept toying with that one for a month and never did the job. Now it didn't even showed the message box anymore, it just autoplayed the cd.

Btw, are you sure it works as you posted in the picture? I myself have

http://hattrick.computergames.ro/forum/ ... 2548&stc=1

_________________
"...and there's Pantano having an 'I'll go join that crash' moment." - Martin Brundle (UK F1 commentator)


Top
 Profile  
 
 Post subject:
PostPosted: Wed Aug 04, 2004 4:34 am 
Member
User avatar

Joined: Mon Jul 02, 2001 2:01 pm
Posts: 1298
Location: Lost in Translation
And there's the possibility to enable to turn off autoplay on All Drives or CD-Rom drives (including DVD-Rom).

_________________
"...and there's Pantano having an 'I'll go join that crash' moment." - Martin Brundle (UK F1 commentator)


Top
 Profile  
 
 Post subject:
PostPosted: Wed Aug 04, 2004 4:55 am 
Glow Ball
User avatar

Joined: Tue Feb 02, 1999 7:00 pm
Posts: 11
Both methods work, Fila. But your link doesn't.... which might explain something about why you couldn't figure this stuff out.

Anyway, yes, the group policy, I think, is the better way to go.


Top
 Profile  
 
 Post subject:
PostPosted: Wed Aug 04, 2004 7:40 am 
Member
User avatar

Joined: Mon Jul 02, 2001 2:01 pm
Posts: 1298
Location: Lost in Translation
Phineus wrote:
Both methods work, Fila. But your link doesn't.... which might explain something about why you couldn't figure this stuff out.

Anyway, yes, the group policy, I think, is the better way to go.


Smartass again. hehe

You have to have my login infos to be able to see the link i guess.

http://www.lenau.com/fila/Pics/offautoplay.jpg

Better now?

_________________
"...and there's Pantano having an 'I'll go join that crash' moment." - Martin Brundle (UK F1 commentator)


Top
 Profile  
 
 Post subject:
PostPosted: Wed Aug 04, 2004 8:57 am 
Glow Ball
User avatar

Joined: Tue Feb 02, 1999 7:00 pm
Posts: 11
Your way allows you to still autoplay cd's.

My way shuts down absolutely everything, no exceptions.


Top
 Profile  
 
 Post subject:
PostPosted: Wed Aug 04, 2004 11:55 am 
Member
User avatar

Joined: Mon Jul 02, 2001 2:01 pm
Posts: 1298
Location: Lost in Translation
I don't believe you.

I tried, i inserted game cd's with autolunch and nothing works anymore. Neither autolaunch on game cd's, the dern windows pop-up folder for data cd's, the thingie for dvd's, the thingie for audio cd's. Nodda!

And it makes logic because you have to enable autoplay off.

Well at least that's how it works on my computer and we all know the virtual memory story we had on mine :)

_________________
"...and there's Pantano having an 'I'll go join that crash' moment." - Martin Brundle (UK F1 commentator)


Top
 Profile  
 
 Post subject:
PostPosted: Wed Aug 04, 2004 12:01 pm 
Glow Ball
User avatar

Joined: Tue Feb 02, 1999 7:00 pm
Posts: 11
When you start burning out motherboards, you'll know you're on the right track. At least, that's my story and I'm sticking to it.


Top
 Profile  
 
 Post subject:
PostPosted: Mon Sep 27, 2004 4:37 pm 
[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer]
"NoDriveTypeAutoRun"=dword:00000091

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Cdrom]
"AutoRun"=dword:00000001

simple, goto the location that in the info above(using regedit: start > run > regedit) then delete "NoDriveTypeAutoRun"=dword:00000091 in the first one and delete "AutoRun"=dword:00000001 in the second one and you should be good to go. if you need the autorun turned back on then make a new file using notepad and enter:

REGEDIT4

[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer]
"NoDriveTypeAutoRun"=dword:00000091

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Cdrom]
"AutoRun"=dword:00000001

then save it as reset.reg(note: .reg not .txt).


Top
  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 9 posts ] 


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group